B2000++ Model Browser Short User Guide

SMR Engineering & Development SA

Version 4.2

Legal Notice

1. Introduction

The b2browser browser is a GUI based tool for inspecting B2000++ models. It allows for viewing

  • Meshes (nodes, elements, node and element lists)

  • Materials

  • Boundary conditions

  • Case information

  • Solutions (all solutions found)

  • Other Data

  • The B2000++ Log file

The b2browser is a 'high-level' tool, i.e. it formats database information in a comprehensible way for the user. To read a B2000++ database in a 'raw' way, i.e. dataset by dataset, without any interpretation, please make use of the mcbrowsern tool.

2. Launching the b2browser

The b2browser can be started from a shell or with the GUI. See b2browser reference page how to start the b2browser from a shell.

Example of starting the b2browser from the shell (scordelis_lo roof example):

If the b2browser is launched from the desktop, such as Gnome, any model database or report file must be opened with the File menu.

3. Browser keys

The following b2browser keys for extracting and displaying of data are acive during a session:

  • Left Mouse Key : Selects an entry and displays text.

  • SHIFT Left Mouse Key : Selects an entry and displays a graph (if applicable [1] and graphics software installed).

  • CTRL Left Mouse Key : Selects an entry and exports data in a CSV (comma separated value) file (if applicable [1]).

4. Using the b2browser

The b2browser is GUI based and its operation is mostly self-explanatory. When starting the b2browser with a B2000++ database the main page pops up:

All entries are selected by clicking the left mouse button.

The top row of the main page contains the File and Help menus, as well as additional global menus and buttons. The File menu allows for opening B2000++ databases and the report file (see below).

The actual browser area contains tabs (A), each tab holding a B2000++ database. A list with all elements that can be browsed is presented in B and the content of an element is presented in C and D, C being the 'column header'. Finally, G displays messages.

The list with all elements that can be browsed (B) starts with the B2000++ Log entry, which displays the B2000++ log file (if available). All other entries pertain to the B2000++ model. If an entry id preceded by the ▹ symbol, clicking on ▹ will unfold the entry. In the example above, the displacements of Case 1 are selected and displayed (E).

The report capability copies the data displayed in C to a text file, adding the data to the report file. The R+ button (F) performs this operation. The default file name is report.txt, and the file is located in the same directory as the B2000++ database.

Preferences can be set with the Preferences entry of the File Menu.



[1] Some entries, such as reaction forces during nonlinear analysis, allow for extracting and displaying of graphs, such as stroke vs. load diagrams.